blob: acfb97655ae5e33d2f61171d84ad4ac7d074376c [file] [log] [blame]
Patrick Williamsde0582f2022-04-08 10:23:27 -05001SUMMARY = "A library to access weather information from online services"
2
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5
6GNOMEBASEBUILDCLASS = "meson"
7GNOMEBN = "libgweather"
8S = "${WORKDIR}/${GNOMEBN}-${PV}"
9
10inherit gnomebase gsettings gobject-introspection gettext gtk-doc vala features_check upstream-version-is-even
11
12SRC_URI[archive.sha256sum] = "440d44801b6f72b48c676e5e37f9109cfee1394fd74cc92725e1b1ba4fae834c"
13
14# gobject-introspection is mandatory and cannot be configured
15REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
16GIR_MESON_OPTION = ""
17
18GTKDOC_MESON_OPTION = "gtk_doc"
19
20DEPENDS = " \
21 geocode-glib \
22 gtk+3 \
23 json-glib \
24 libsoup-2.4 \
25 python3-pygobject-native \
26"
27
28FILES:${PN} += " \
29 ${datadir}/libgweather-4 \
30 ${libdir}/libgweather-4 \
31"