blob: 0572cc801be7991a6815c4f2e4ce85fcf13ae660 [file] [log] [blame]
Patrick Williamsde0582f2022-04-08 10:23:27 -05001SUMMARY = "UPower is an abstraction for enumerating power devices"
2DESCRIPTION = "UPower is an abstraction for enumerating power devices, listening to device events and querying history and statistics."
3LICENSE = "GPL-2.0-or-later"
4LIC_FILES_CHKSUM = "file://COPYING;md5=0de8fbf1d97a140d1d93b9f14dcfbf08"
5
6DEPENDS = " \
7 intltool-native \
8 libusb1 \
9 libgudev \
10 glib-2.0 \
11 dbus-glib \
12"
13
14SRC_URI = "git://gitlab.freedesktop.org/upower/upower.git;protocol=https;branch=master"
15SRCREV = "c889154ec8e3e2239db9260d48b2e198d72ba002"
16S = "${WORKDIR}/git"
17
18UPSTREAM_CHECK_GITTAGREGEX = "UPOWER_(?P<pver>\d+(\_\d+)+)"
19
20GIR_MESON_ENABLE_FLAG = "enabled"
21GIR_MESON_DISABLE_FLAG = "disabled"
22GTKDOC_MESON_OPTION = "gtk-doc"
23
24inherit meson pkgconfig gtk-doc gettext gobject-introspection systemd
25
26PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
27PACKAGECONFIG[idevice] = "-Didevice=enabled,-Didevice=disabled,libimobiledevice libplist"
28PACKAGECONFIG[systemd] = "-Dsystemdsystemunitdir=${systemd_system_unitdir},-Dsystemdsystemunitdir=no -Dudevrulesdir=${base_libdir}/udev/rules.d,systemd"
29
30EXTRA_OEMESON = " \
31 -Dos_backend=linux \
32 -Dman=false \
33"
34
35SYSTEMD_SERVICE:${PN} = "upower.service"
36# don't start on boot by default - dbus does that on demand
37SYSTEMD_AUTO_ENABLE = "disable"
38
39RDEPENDS:${PN} += "dbus"
40RRECOMMENDS:${PN} += "pm-utils"
41FILES:${PN} += " \
42 ${datadir}/dbus-1/ \
43 ${base_libdir}/udev/* \
44"