blob: 953ecfd055c0f0688b49b74703044deda026921c [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Hardware RNG based on CPU timing jitter"
2DESCRIPTION = "The Jitter RNG provides a noise source using the CPU execution timing jitter. \
3It does not depend on any system resource other than a high-resolution time \
4stamp. It is a small-scale, yet fast entropy source that is viable in almost \
5all environments and on a lot of CPU architectures."
6HOMEPAGE = "http://www.chronox.de/jent.html"
7LICENSE = "GPLv2+ | BSD"
Andrew Geisslerc723b722021-01-08 16:14:09 -06008LIC_FILES_CHKSUM = "file://COPYING;md5=fb16b29576d4c43a9dcd6a40fb3310c7 \
Andrew Geissler82c905d2020-04-13 13:39:40 -05009 file://COPYING.gplv2;md5=eb723b61539feef013de476e68b5c50a \
10 file://COPYING.bsd;md5=66a5cedaf62c4b2637025f049f9b826f \
11 "
Andrew Geisslerc723b722021-01-08 16:14:09 -060012SRC_URI = "git://github.com/smuellerDD/jitterentropy-library.git"
13SRCREV = "a37e57d9b939d1f93a1b92e1486edd44a3c1cb4c"
Andrew Geissler82c905d2020-04-13 13:39:40 -050014S = "${WORKDIR}/git"
15
16do_configure[noexec] = "1"
17
18LDFLAGS += "-Wl,-O0"
19
20do_install () {
21 oe_runmake install INCDIR="/include" \
22 DESTDIR="${D}" \
23 PREFIX="${exec_prefix}" \
24 LIBDIR="${baselib}" \
25 INSTALL_STRIP="install"
26}
27