blob: 170463f85a23be47257a47993d9ec6bc6cce46af [file] [log] [blame]
Potin Laie096c412022-09-01 14:12:25 +08001LICENSE = "Apache-2.0"
2LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
3
4inherit obmc-phosphor-systemd
5
6RDEPENDS:${PN} += " bash motor-ctrl"
7
8SRC_URI += " \
9 file://bletchley-system-state-init \
10 file://bletchley-system-state-init@.service \
11 "
12
13do_install() {
14 install -d ${D}${libexecdir}
15 install -m 0755 ${WORKDIR}/bletchley-system-state-init ${D}${libexecdir}
16}
17
18
19TGT = "${SYSTEMD_DEFAULT_TARGET}"
20BLETCHLEY_SYS_ST_INIT_INSTFMT="../bletchley-system-state-init@.service:${TGT}.wants/bletchley-system-state-init@{0}.service"
21
22SYSTEMD_SERVICE:${PN} += "bletchley-system-state-init@.service"
23SYSTEMD_LINK:${PN} += "${@compose_list(d, 'BLETCHLEY_SYS_ST_INIT_INSTFMT', 'OBMC_HOST_INSTANCES')}"