blob: c10b7ce0498b3cc2c579886eb1f9d45d309c1512 [file] [log] [blame]
Andrew Geisslerda686ac2019-01-23 14:37:55 -06001FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
Andrew Jeffery274f96a2020-04-03 16:20:51 +10302
3SRC_URI_remove = "file://${BPN}.conf"
4SRC_URI += "file://server.ttyVUART0.conf"
Andrew Jeffery1688b152020-02-17 15:34:34 +10305
6install_concurrent_console_config() {
7 # Install configuration for the servers and clients. Keep commandline
8 # compatibility with previous configurations by defaulting to not
9 # specifying a socket-id for VUART0/2200
10 install -m 0755 -d ${D}${sysconfdir}/${BPN}
11
12 # Remove the default client configuration as we don't to define a
13 # socket-id for the 2200 console
14 rm -f ${D}${sysconfdir}/${BPN}/client.2200.conf
15
16 # However, now link to /dev/null as a way of not specifying a
17 # socket-id while having a configuration file present. We need to
18 # provide a configuration path to meet the requirements of the packaged
19 # unit file.
20 ln -sr ${D}/dev/null ${D}${sysconfdir}/${BPN}/client.2200.conf
21
22 # We need to populate socket-id for remaining consoles
23 install -m 0644 ${WORKDIR}/client.2201.conf ${D}${sysconfdir}/${BPN}/
24
25 # Install configuration for remaining servers - the base recipe
26 # installs the configuration for the first.
27 install -m 0644 ${WORKDIR}/server.ttyVUART1.conf ${D}${sysconfdir}/${BPN}/
28}
29
30SRC_URI_append_rainier = " file://client.2201.conf"
31SRC_URI_append_rainier = " file://server.ttyVUART1.conf"
32
33REGISTERED_SERVICES_${PN}_append_rainier = " obmc_console_guests:tcp:2201:"
34
35SYSTEMD_SERVICE_${PN}_append_rainier = " obmc-console-ssh@2200.service \
36 obmc-console-ssh@2201.service \
37 "
38SYSTEMD_SERVICE_${PN}_remove_rainier = "obmc-console-ssh.socket"
39
40FILES_${PN}_remove_rainier = "/lib/systemd/system/obmc-console-ssh@.service.d/use-socket.conf"
41
42EXTRA_OECONF_append_rainier = " --enable-concurrent-servers"
43
44do_install_append_rainier() {
45 install_concurrent_console_config
46}
Andrew Jeffery35c33cc2020-04-02 15:29:34 +103047
48SRC_URI_append_witherspoon-tacoma = " file://client.2201.conf"
49SRC_URI_append_witherspoon-tacoma = " file://server.ttyVUART1.conf"
50
51REGISTERED_SERVICES_${PN}_append_witherspoon-tacoma = " obmc_console_guests:tcp:2201:"
52
53SYSTEMD_SERVICE_${PN}_append_witherspoon-tacoma = " obmc-console-ssh@2200.service \
54 obmc-console-ssh@2201.service \
55 "
56SYSTEMD_SERVICE_${PN}_remove_witherspoon-tacoma = "obmc-console-ssh.socket"
57
58FILES_${PN}_remove_witherspoon-tacoma = "/lib/systemd/system/obmc-console-ssh@.service.d/use-socket.conf"
59
60EXTRA_OECONF_append_witherspoon-tacoma = " --enable-concurrent-servers"
61
62do_install_append_witherspoon-tacoma() {
63 install_concurrent_console_config
64}