blob: b977ce0ea515529bf2d1a80af069a6f8b1d545cf [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Utilities and libraries for handling compiled object files"
2HOMEPAGE = "https://sourceware.org/elfutils"
3SECTION = "base"
4LICENSE = "(GPLv3 & Elfutils-Exception)"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6DEPENDS = "libtool bzip2 zlib virtual/libintl"
7DEPENDS_append_libc-musl = " argp-standalone fts "
8SRC_URI = "https://sourceware.org/elfutils/ftp/${PV}/${BP}.tar.bz2"
9SRC_URI[md5sum] = "52adfa40758d0d39e5d5c57689bf38d6"
10SRC_URI[sha256sum] = "b88d07893ba1373c7dd69a7855974706d05377766568a7d9002706d5de72c276"
11
12SRC_URI += "\
13 file://dso-link-change.patch \
14 file://Fix_elf_cvt_gunhash.patch \
15 file://fixheadercheck.patch \
16 file://0001-elf_getarsym-Silence-Werror-maybe-uninitialized-fals.patch \
17 file://0001-remove-the-unneed-checking.patch \
18 file://0001-fix-a-stack-usage-warning.patch \
19 file://aarch64_uio.patch \
20 file://Fix_one_GCC7_warning.patch \
21 file://shadow.patch \
22"
23
24# pick the patch from debian
25# http://ftp.de.debian.org/debian/pool/main/e/elfutils/elfutils_0.168-0.2.debian.tar.xz
26SRC_URI += "\
27 file://debian/hppa_backend.diff \
28 file://debian/arm_backend.diff \
29 file://debian/mips_backend.diff \
30 file://debian/testsuite-ignore-elflint.diff \
31 file://debian/mips_readelf_w.patch \
32 file://debian/kfreebsd_path.patch \
33 file://debian/0001-Ignore-differences-between-mips-machine-identifiers.patch \
34 file://debian/0002-Add-support-for-mips64-abis-in-mips_retval.c.patch \
35 file://debian/0003-Add-mips-n64-relocation-format-hack.patch \
36 file://debian/hurd_path.patch \
37 file://debian/ignore_strmerge.diff \
38"
39# Fix the patches from Debian with GCC7
40SRC_URI += "file://fallthrough.patch"
41SRC_URI_append_libc-musl = " file://0001-build-Provide-alternatives-for-glibc-assumptions-hel.patch "
42
43# The buildsystem wants to generate 2 .h files from source using a binary it just built,
44# which can not pass the cross compiling, so let's work around it by adding 2 .h files
45# along with the do_configure_prepend()
46
47inherit autotools gettext
48
49EXTRA_OECONF = "--program-prefix=eu- --without-lzma"
50EXTRA_OECONF_append_class-native = " --without-bzlib"
51EXTRA_OECONF_append_libc-uclibc = " --enable-uclibc"
52
53do_install_append() {
54 if [ "${TARGET_ARCH}" != "x86_64" ] && [ -z `echo "${TARGET_ARCH}"|grep 'i.86'` ];then
55 rm -f ${D}${bindir}/eu-objdump
56 fi
57}
58
59# we can not build complete elfutils when using uclibc
60# but some recipes e.g. gcc 4.5 depends on libelf so we
61# build only libelf for uclibc case
62
63EXTRA_OEMAKE_libc-uclibc = "-C libelf"
64EXTRA_OEMAKE_class-native = ""
65EXTRA_OEMAKE_class-nativesdk = ""
66
67ALLOW_EMPTY_${PN}_libc-musl = "1"
68
69BBCLASSEXTEND = "native nativesdk"
70
71# Package utilities separately
72PACKAGES =+ "${PN}-binutils libelf libasm libdw"
73FILES_${PN}-binutils = "\
74 ${bindir}/eu-addr2line \
75 ${bindir}/eu-ld \
76 ${bindir}/eu-nm \
77 ${bindir}/eu-readelf \
78 ${bindir}/eu-size \
79 ${bindir}/eu-strip"
80
81FILES_libelf = "${libdir}/libelf-${PV}.so ${libdir}/libelf.so.*"
82FILES_libasm = "${libdir}/libasm-${PV}.so ${libdir}/libasm.so.*"
83FILES_libdw = "${libdir}/libdw-${PV}.so ${libdir}/libdw.so.* ${libdir}/elfutils/lib*"
84# Some packages have the version preceeding the .so instead properly
85# versioned .so.<version>, so we need to reorder and repackage.
86#FILES_${PN} += "${libdir}/*-${PV}.so ${base_libdir}/*-${PV}.so"
87#FILES_SOLIBSDEV = "${libdir}/libasm.so ${libdir}/libdw.so ${libdir}/libelf.so"
88
89# The package contains symlinks that trip up insane
90INSANE_SKIP_${MLPREFIX}libdw = "dev-so"