blob: a89b659ae89beb7f1a788fd37955bcdf256fb3bc [file] [log] [blame]
James Feiste3322992018-10-04 16:15:37 -07001SUMMARY = "JSON for modern C++"
2HOMEPAGE = "https://nlohmann.github.io/json/"
3SECTION = "libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=9a8ae1c2d606c432a2aa2e2de15be22a"
6
7SRC_URI = "git://github.com/nlohmann/json.git"
8
9PV = "3.2.0+git${SRCPV}"
10
11SRCREV = "8c20571136f2d5351b379a06ad6591bd980880fe"
12
13S = "${WORKDIR}/git"
14
15inherit cmake
16
17EXTRA_OECMAKE += "-DJSON_BuildTests=OFF"
18
19# nlohmann-json is a header only C++ library, so the main package will be empty.
20
21RDEPENDS_${PN}-dev = ""
22
23BBCLASSEXTEND = "native nativesdk"