blob: 488847ac4060f39211059c47f031d6d53054699d [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "A system tool for maintaining the /etc/rc*.d hierarchy"
2DESCRIPTION = "Chkconfig is a basic system utility. It updates and queries runlevel \
3information for system services. Chkconfig manipulates the numerous \
4symbolic links in /etc/rc.d, to relieve system administrators of some \
5of the drudgery of manually editing the symbolic links."
6
7RECIPE_NO_UPDATE_REASON = "Version 1.5 requires selinux"
8
9HOMEPAGE = "http://fedorahosted.org/releases/c/h/chkconfig"
10
11LICENSE = "GPLv2"
12LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
13
14DEPENDS = "libnewt popt"
15PROVIDES += "virtual/update-alternatives"
16
17PR = "r7"
18
19SRC_URI = "http://fedorahosted.org/releases/c/h/chkconfig/${BPN}-${PV}.tar.bz2"
20
21SRC_URI[md5sum] = "c2039ca67f2749fe0c06ef7c6f8ee246"
22SRC_URI[sha256sum] = "18b497d25b2cada955c72810e45fcad8280d105f17cf45e2970f18271211de68"
23
24inherit gettext
25
26# Makefile uses RPM_OPT_FLAGS to construct CFLAGS
27#
28EXTRA_OEMAKE = "\
29 'RPM_OPT_FLAGS=${CFLAGS}' \
30 'LDFLAGS=${LDFLAGS}' \
31 'BINDIR=${base_sbindir}' \
32 'SBINDIR=${sbindir}' \
33 'MANDIR=${mandir}' \
34 'ALTDIR=${localstatedir}/lib/alternatives' \
35 'ALTDATADIR=${sysconfdir}/alternatives' \
36"
37
38do_unpack[postfuncs] += "obey_variables"
39do_unpack[vardeps] += "obey_variables"
40obey_variables () {
41 sed -i -e 's,/etc,${sysconfdir},; s,/lib/systemd,${base_libdir}/systemd,' ${S}/leveldb.h
42 sed -i -e 's,/etc/alternatives,${sysconfdir}/alternatives,' \
43 -e 's,/var/lib/alternatives,${localstatedir}/lib/alternatives,' \
44 -e 's,/usr/share/locale,${datadir}/locale,' ${S}/alternatives.c
45}
46
47do_install() {
48 oe_runmake 'DESTDIR=${D}' 'INSTALLNLSDIR=${D}${datadir}/locale' \
49 'BINDIR=${sbindir}' install
50 install -d ${D}${sysconfdir}/chkconfig.d
51}
52
53PACKAGES =+ "${PN}-alternatives ${PN}-alternatives-doc"
54SUMMARY_${PN}-alternatives = "Maintain symbolic links determining default commands"
55DESCRIPTION_${PN}-alternatives = "alternatives creates, removes, maintains and displays \
56information about the symbolic links comprising the alternatives system."
57SUMMARY_${PN}-alternatives-doc = "${SUMMARY_${PN}-alternatives} - Documentation files"
58DESCRIPTION_${PN}-alternatives-doc = "${DESCRIPTION_${PN}-alternatives} \
59This package contains documentation."
60RPROVIDES_${PN}-alternatives += "update-alternatives"
61RCONFLICTS_${PN}-alternatives = "update-alternatives-opkg update-alternatives-dpkg"
62FILES_${PN}-alternatives = "${sbindir}/alternatives ${sbindir}/update-alternatives \
63 ${sysconfdir}/alternatives ${localstatedir}/lib/alternatives"
64FILES_${PN}-alternatives-doc = "${mandir}/man8/alternatives.8 \
65 ${mandir}/man8/update-alternatives.8"