blob: 302e418a9d5a96c468fdf5d5d8425acce164a440 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "A library for text mode user interfaces"
2
3DESCRIPTION = "Newt is a programming library for color text mode, widget based user \
4interfaces. Newt can be used to add stacked windows, entry widgets, \
5checkboxes, radio buttons, labels, plain text fields, scrollbars, \
6etc., to text mode user interfaces. This package also contains the \
7shared library needed by programs built with newt, as well as a \
8/usr/bin/dialog replacement called whiptail. Newt is based on the \
9slang library."
10
11HOMEPAGE = "https://fedorahosted.org/newt/"
12SECTION = "libs"
13
14LICENSE = "LGPLv2"
15LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
16
17# slang needs to be >= 2.2
18DEPENDS = "slang popt"
19
20SRC_URI = "https://fedorahosted.org/releases/n/e/newt/newt-${PV}.tar.gz \
21 file://remove_slang_include.patch \
22 file://fix_SHAREDDIR.patch \
23 file://cross_ar.patch \
24"
25
26SRC_URI[md5sum] = "685721bee1a318570704b19dcf31d268"
27SRC_URI[sha256sum] = "771b0e634ede56ae6a6acd910728bb5832ac13ddb0d1d27919d2498dab70c91e"
28
29S = "${WORKDIR}/newt-${PV}"
30
31EXTRA_OECONF = "--without-tcl --without-python"
32
33inherit autotools-brokensep
34
35CLEANBROKEN = "1"
36
37export STAGING_INCDIR
38export STAGING_LIBDIR
39
40export BUILD_SYS
41export HOST_SYS
42
43PACKAGES_prepend = "whiptail "
44
45do_configure_prepend() {
46 sh autogen.sh
47}
48
49do_compile_prepend() {
50 # Make sure the recompile is OK
51 rm -f ${B}/.depend
52}
53
54FILES_whiptail = "${bindir}/whiptail"
55
56BBCLASSEXTEND = "native"