blob: b05a59dc70a01d23c7b6f3d6441c35aa00d8939a [file] [log] [blame]
Andrew Geisslere34f8962021-04-15 15:53:51 -05001DESCRIPTION = "Parallelism library for C++ - runtime files \
2 TBB is a library that helps you leverage multi-core processor \
3 performance without having to be a threading expert. It represents a \
4 higher-level, task-based parallelism that abstracts platform details \
5 and threading mechanism for performance and scalability."
6HOMEPAGE = "https://software.intel.com/en-us/tbb"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=86d3f3a95c324c9479bd8986968f4327"
9
10DEPENDS_append_libc-musl = " libucontext"
11
12BRANCH = "onetbb_2021"
13SRCREV = "2dba2072869a189b9fdab3ffa431d3ea49059a19"
14SRC_URI = "git://github.com/oneapi-src/oneTBB.git;protocol=https;branch=${BRANCH} \
15 file://0001-mallinfo-is-glibc-specific-API-mark-it-so.patch \
16 file://GLIBC-PREREQ-is-not-defined-on-musl.patch \
17 file://0001-CMakeLists.txt-exclude-riscv64-riscv32.patch \
18 file://0001-Disable-use-of-_tpause-instruction.patch \
19"
20
21S = "${WORKDIR}/git"
22
23inherit cmake
24
25# test build fails, error: 'mallinfo mallinfo()' is deprecated
26EXTRA_OECMAKE += " \
27 -DTBB_TEST=OFF \
28 -DCMAKE_BUILD_TYPE=Release \
29 "
30
31
32# fails with thumb enabled:
33# | arm-oe-linux-gnueabi-g++ -march=armv7-a -mthumb -mthumb-interwork -mfloat-abi=softfp -mfpu=neon -mtune=cortex-a9 -mcpu=cortex-a9 -D__ARM__ -D__LINUX_ARM_ARCH__=7 -funwind-tables -mvectorize-with-neon-quad -rdynamic --sysroot=/OE/sysroots/m14tv -c -MMD -DTBB_USE_DEBUG -g -O0 -DUSE_PTHREAD -fPIC -D__TBB_BUILD=1 -Wall -Wno-parentheses -Wno-non-virtual-dtor -O2 -pipe -g -feliminate-unused-debug-types -fpermissive -fvisibility-inlines-hidden -I../../src -I../../src/rml/include -I../../include ../../src/tbb/concurrent_queue.cpp
34# | {standard input}: Assembler messages:
35# | {standard input}:250: Error: thumb conditional instruction should be in IT block -- `strexeq r2,r3,[r4]'
36# ...
37# | make[1]: *** [concurrent_queue.o] Error 1
38ARM_INSTRUCTION_SET = "arm"
39
40ASNEEDED = ""
41
42LDFLAGS_append_mips = " -latomic"
43LDFLAGS_append_mipsel = " -latomic"
44
45LDFLAGS_append_libc-musl = " -lucontext"