blob: 52c254b28834dd45499f5262dff90ad5307ea975 [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "Password and keyring managing daemon"
2HOMEPAGE = "http://www.gnome.org/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4SECTION = "x11/gnome"
5
6LICENSE = "GPLv2+ & LGPLv2+ & LGPLv2.1+"
7LIC_FILES_CHKSUM = " \
8 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
9 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
10"
11
12DEPENDS = " \
13 glib-2.0-native \
14 gtk+3 \
15 gcr \
16 libgcrypt \
17 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)} \
18"
19
20inherit gnomebase gsettings features_check remove-libtool gettext upstream-version-is-even
21
22REQUIRED_DISTRO_FEATURES = "x11"
23
24SRC_URI[archive.md5sum] = "7c8fd85e46ed4ba1add0288b2ead9aec"
25SRC_URI[archive.sha256sum] = "e9cda9542a3e37c61636145e7e9e2513c569092ea8020752a834e1f40ad41943"
26SRC_URI += " \
27 file://0001-Set-paths-to-ssh-agent-and-ssh-add-by-configure-opti.patch \
28 file://musl.patch \
29"
30
31PACKAGECONFIG ??= "ssh-agent"
32PACKAGECONFIG[ssh-agent] = "--enable-ssh-agent --with-ssh-agent-path=${bindir}/ssh-agent --with-ssh-add-path=${bindir}/ssh-add,--disable-ssh-agent,,openssh-misc"
33
34EXTRA_OECONF = " \
35 --disable-doc \
36 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '--enable-pam --with-pam-dir=${base_libdir}/security', '--disable-pam', d)} \
37"
38
39FILES_${PN} += " \
40 ${datadir}/dbus-1/services \
41 ${datadir}/p11-kit \
42 ${base_libdir}/security/*${SOLIBSDEV} \
43 ${libdir}/pkcs11/gnome-keyring-pkcs11.so \
44"
45
46# fix | gnome-keyring-daemon: insufficient process capabilities, unsecure memory might get used
47# This does not make it through pseudo so perform on-target - sigh
48pkg_postinst_ontarget_${PN} () {
49 setcap cap_ipc_lock+ep `which gnome-keyring-daemon`
50}
51RDEPENDS_${PN} += "libcap-bin"