blob: 3dbbcafbdf7fbbc156422982380f259336ff1706 [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "Tracker miners and metadata extractors"
2LICENSE = "GPLv2 & LGPLv2.1"
3LIC_FILES_CHKSUM = " \
4 file://COPYING.GPL;md5=ee31012bf90e7b8c108c69f197f3e3a4 \
5 file://COPYING.LGPL;md5=2d5025d4aa3495befef8f17206a5b0a1 \
6"
7
8DEPENDS = " \
9 intltool-native \
10 tracker \
11 zlib \
12"
13
14GNOMEBASEBUILDCLASS = "meson"
15
16inherit gnomebase gsettings gobject-introspection vala gtk-doc manpages bash-completion features_check
17
18SRC_URI[archive.md5sum] = "0321d8f4ad27e3fccdbc8384e5b3cb83"
19SRC_URI[archive.sha256sum] = "7b1de06a7a79ea1c7813c8a21f8cd1c55f2b95f799cf9f47f0204f3be8a590e0"
20SRC_URI += "file://0001-meson.build-Just-warn-if-we-build-without-libseccomp.patch"
21
22# gobject-introspection is mandatory and cannot be configured
23REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
24UNKNOWN_CONFIGURE_WHITELIST_append = " introspection"
25
26PACKAGECONFIG ??= " \
27 ffmpeg \
28 flac \
29 gexiv2 \
30 gstreamer \
31 icu \
32 libexif \
33 libgsf \
34 jpeg \
35 png \
36 tiff \
37 xml \
38 pdf \
39"
40
41PACKAGECONFIG[ffmpeg] = ",,ffmpeg"
42PACKAGECONFIG[flac] = "-Dflac=enabled,-Dflac=disabled,flac"
43PACKAGECONFIG[gexiv2] = ",,gexiv2"
44PACKAGECONFIG[gstreamer] = ",,gstreamer1.0 gstreamer1.0-plugins-base"
45PACKAGECONFIG[gupnp] = ",,gupnp-dlna"
46PACKAGECONFIG[icu] = ",,icu"
47PACKAGECONFIG[libexif] = "-Dexif=enabled,-Dexif=disabled,libexif"
48PACKAGECONFIG[libgsf] = "-Dgsf=enabled,-Dgsf=disabled,libgsf"
49PACKAGECONFIG[jpeg] = "-Djpeg=enabled,-Djpeg=disabled,jpeg"
50PACKAGECONFIG[png] = "-Dpng=enabled,-Dpng=disabled,libpng"
51PACKAGECONFIG[tiff] = "-Dtiff=enabled,-Dtiff=disabled,tiff"
52PACKAGECONFIG[xml] = "-Dxml=enabled,-Dxml=disabled,libxml2"
53PACKAGECONFIG[vorbis] = "-Dvorbis=enabled,-Dvorbis=disabled,libvorbis"
54PACKAGECONFIG[pdf] = "-Dpdf=enabled,-Dpdf=disabled,poppler"
55PACKAGECONFIG[upower] = ",,upower"
56
57# For security reasons it is strongly recommended to set add meta-security in
58# your layers and 'libseccomp' to PACKAGECONFIG".
59PACKAGECONFIG[libseccomp] = ",,libseccomp"
60# not yet in meta-gnome
61PACKAGECONFIG[rss] = "-Dminer_rss=true,-Dminer_rss=false,libgrss"
62
63FILES_${PN} += " \
64 ${datadir}/dbus-1 \
65 ${datadir}/tracker \
66 ${libdir}/tracker-miners-2.0 \
67 ${systemd_user_unitdir} \
68"