blob: edc489000517b125872e60f293d25351866555ce [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001DESCRIPTION = "D-Bus interfaces for querying and manipulating user account information"
2HOMEPAGE = "https://www.freedesktop.org/wiki/Software/AccountsService/"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
5
6DEPENDS = " \
7 dbus \
8 polkit \
9"
10
11inherit meson gobject-introspection gtk-doc features_check systemd
12
13REQUIRED_DISTRO_FEATURES = "polkit"
14
15SRC_URI = "https://www.freedesktop.org/software/${BPN}/${BPN}-${PV}.tar.xz"
16SRC_URI_append_libc-musl = " \
17 file://0001-musl-Hack-to-fix-build.patch \
18 file://0002-musl-add-missing-fgetspent_r.patch \
19"
20SRC_URI[md5sum] = "6e4c6fbd490260cfe17de2e76f5d803a"
21SRC_URI[sha256sum] = "ff2b2419a7e06bd9cb335ffe391c7409b49a0f0130b890bd54692a3986699c9b"
22
23GTKDOC_MESON_OPTION = "gtk_doc"
24
25PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
26PACKAGECONFIG[systemd] = "-Dsystemd=true, -Dsystemd=false -Dsystemdsystemunitdir='no', systemd"
27
28SYSTEMD_SERVICE_${PN} = "accounts-daemon.service"
29
30FILES_${PN} += " \
31 ${datadir}/dbus-1 \
32 ${datadir}/polkit-1 \
33"