blob: d047caef5f2fce8500c543c45079747f464daca4 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Gst-Shark Tracers"
2DESCRIPTION = "Benchmarks and profiling tools for GStreamer"
3HOMEPAGE = "https://developer.ridgerun.com/wiki/index.php?title=GstShark"
4SECTION = "multimedia"
5LICENSE = "GPLv2+"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=e1caa368743492879002ad032445fa97"
8
9DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad "
10
11SRCBRANCH ?= "master"
12
Brad Bishope42b3e32020-01-15 22:08:42 -050013PV = "0.6.1"
14
15SRCREV_base = "c41a05cc9e2310c2f73eda4b4f0b4477bf4479c5"
16SRCREV_common = "88e512ca7197a45c4114f7fa993108f23245bf50"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017
18SRC_URI = " \
19 git://github.com/RidgeRun/gst-shark.git;protocol=https;branch=${SRCBRANCH};name=base \
Brad Bishope42b3e32020-01-15 22:08:42 -050020 git://gitlab.freedesktop.org/gstreamer/common.git;protocol=https;destsuffix=git/common;name=common; \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080021 "
22
23S = "${WORKDIR}/git"
24
25PACKAGECONFIG_CONFARGS = " \
26 --disable-graphviz \
27 --enable-gtk-doc=no \
28"
29
30FILES_${PN} += "\
31 ${libdir}/gstreamer-1.0/libgstsharktracers.so \
32 ${libdir}/gstreamer-1.0/libgstsharktracers.la \
33"
34
35inherit autotools gettext
36
37do_configure() {
38 ${S}/autogen.sh --noconfigure
39 oe_runconf
40}