blob: aedd53a7a407433a7a76be32f35397661c7936b2 [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001DESCRIPTION="Protocol Buffers with small code size"
2LICENSE="Zlib"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=9db4b73a55a3994384112efcdb37c01f"
4
5DEPENDS = "protobuf-native"
6
7SRC_URI = "git://github.com/nanopb/nanopb.git"
8SRCREV = "70f0de9877b1ce12abc0229d5df84db6349fcbfc"
9
10S = "${WORKDIR}/git"
11
12inherit cmake pythonnative
13
14do_install_append() {
15 install -Dm 0755 ${S}/generator/nanopb_generator.py ${D}${bindir}/nanopb_generator.py
16 install -Dm 0755 ${S}/generator/protoc-gen-nanopb ${D}${bindir}/protoc-gen-nanopb
17 install -Dm 0755 ${S}/generator/proto/__init__.py ${D}${PYTHON_SITEPACKAGES_DIR}/proto/__init__.py
18}
19
20FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"
21FILES_${PN}-dev += "${libdir}/cmake/${BPN}"
22
23RDEPENDS_${PN} += "\
24 ${PYTHON_PN}-protobuf \
25 protobuf-compiler \
26"
27
28BBCLASSEXTEND = "native nativesdk"