blob: cfa86f04c15c0a0b4809d4a0412454911f98bcd9 [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "Regular expressions library"
2DESCRIPTION = "Oniguruma is a modern and flexible regular expressions library. \
3It encompasses features from different regular expression \
4implementations that traditionally exist in different languages. \
5Character encoding can be specified per regular expression object."
6HOMEPAGE = "https://github.com/kkos/oniguruma"
7LICENSE = "BSD-2-Clause"
8LIC_FILES_CHKSUM = "file://COPYING;md5=1ee043784bdce7503e619b2d1a85798b"
9
10SRC_URI = "\
11 https://github.com/kkos/oniguruma/releases/download/v${PV}/${BP}.tar.gz \
12 file://0001-build-don-t-link-against-host-system-libraries.patch \
13 file://0001-build-enable-serial-tests-automake-option-for-ptest.patch \
14 file://run-ptest \
15"
16
17SRC_URI[md5sum] = "a12d2fe997b789bd87cf63799c091879"
18SRC_URI[sha256sum] = "4669d22ff7e0992a7e93e116161cac9c0949cd8960d1c562982026726f0e6d53"
19
20BINCONFIG = "${bindir}/onig-config"
21
22inherit autotools binconfig-disabled ptest
23
24BBCLASSEXTEND = "native"
25
26do_compile_ptest() {
27 oe_runmake -C test buildtest-TESTS
28}
29
30do_install_ptest() {
31 install -Dm0755 -t ${D}${PTEST_PATH}/tests/ ${B}/test/.libs/*
32}