blob: 0d744e213b998d4103e5123434aa5a3376b7e077 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Smart card library and applications"
2DESCRIPTION = "OpenSC is a tool for accessing smart card devices. Basic\
3functionality (e.g. SELECT FILE, READ BINARY) should work on any ISO\
47816-4 compatible smart card. Encryption and decryption using private\
5keys on the smart card is possible with PKCS\
6such as the FINEID (Finnish Electronic IDentity) card. Swedish Posten\
7eID cards have also been confirmed to work."
8
9HOMEPAGE = "http://www.opensc-project.org/opensc/"
10SECTION = "System Environment/Libraries"
11LICENSE = "LGPLv2+"
12LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
13
14#v0.19.0
15SRCREV = "f1691fc91fc113191c3a8aaf5facd6983334ec47"
16SRC_URI = "git://github.com/OpenSC/OpenSC \
17 file://0001-Remove-redundant-logging.patch \
Brad Bishope42b3e32020-01-15 22:08:42 -050018 file://0001-Fix-misleading-code-indentation.patch \
Brad Bishop19323692019-04-05 15:28:33 -040019 "
Brad Bishop8410d612019-11-25 09:40:59 -050020DEPENDS = "virtual/libiconv openssl"
Brad Bishop19323692019-04-05 15:28:33 -040021
22S = "${WORKDIR}/git"
23inherit autotools pkgconfig bash-completion
24
25EXTRA_OECONF = " \
26 --disable-static \
Brad Bishop19323692019-04-05 15:28:33 -040027 --disable-ctapi \
28 --disable-doc \
29"
30EXTRA_OEMAKE = "DESTDIR=${D}"
31
Brad Bishop8410d612019-11-25 09:40:59 -050032PACKAGECONFIG ??= "pcsc"
33
34PACKAGECONFIG[openct] = "--enable-openct,--disable-openct,openct"
Brad Bishope42b3e32020-01-15 22:08:42 -050035PACKAGECONFIG[pcsc] = "--enable-pcsc,--disable-pcsc,pcsc-lite,pcsc-lite pcsc-lite-lib"
Brad Bishop8410d612019-11-25 09:40:59 -050036
Brad Bishop19323692019-04-05 15:28:33 -040037RDEPENDS_${PN} = "readline"
38
39FILES_${PN} += "\
40 ${libdir}/opensc-pkcs11.so \
41 ${libdir}/onepin-opensc-pkcs11.so \
42 ${libdir}/pkcs11-spy.so \
43"
44FILES_${PN}-dev += "\
45 ${libdir}/pkcs11/opensc-pkcs11.so \
46 ${libdir}/pkcs11/onepin-opensc-pkcs11.so \
47 ${libdir}/pkcs11/pkcs11-spy.so \
48"
Brad Bishop8410d612019-11-25 09:40:59 -050049
50BBCLASSEXTEND = "native"