blob: 935e09cd53340057142cdb3ac59329cd6b9201ea [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001DESRIPTION = "2D barcode scanner toolkit."
2SECTION = "graphics"
3LICENSE = "LGPL-2.1"
4
5DEPENDS = "pkgconfig intltool-native libpng jpeg"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=4015840237ca7f0175cd626f78714ca8"
8
9PV = "0.10+git${SRCPV}"
10
11# iPhoneSDK-1.3.1 tag
12SRCREV = "67003d2a985b5f9627bee2d8e3e0b26d0c474b57"
13SRC_URI = "git://github.com/ZBar/Zbar \
14 file://0001-make-relies-GNU-extentions.patch \
15"
16S = "${WORKDIR}/git"
17
18inherit autotools pkgconfig
19
20PACKAGECONFIG = "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
21
22PACKAGECONFIG[x11] = "--with-x,-without-x,libxcb libx11 libsm libxau libxext libxv libice libxdmcp"
23
24EXTRA_OECONF = "--without-imagemagick --without-qt --without-python --disable-video --without-gtk"
25
26CPPFLAGS += "-Wno-error"
27
28do_install_append() {
29 #remove usr/bin if empty
30 rmdir ${D}${bindir}
31}