blob: cebbee6e61dc68c40f5e65979f2e22eb267f51a8 [file] [log] [blame]
Brad Bishop6c2fd812019-07-21 18:08:31 -04001require u-boot-common-aspeed-sdk_${PV}.inc
2
3SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
4DEPENDS += "mtd-utils"
5
6PROVIDES += "u-boot-fw-utils"
7
Joel Stanley52db5ae2020-03-20 12:17:07 +10308SRC_URI += "file://fw_env_ast2600_nor.config"
Adriana Kobylake4778652020-07-07 13:31:51 -05009SRC_URI += "file://fw_env_ast2600_mmc.config"
10
11ENV_CONFIG_FILE = "fw_env_ast2600_nor.config"
12ENV_CONFIG_FILE_df-phosphor-mmc = "fw_env_ast2600_mmc.config"
Joel Stanley52db5ae2020-03-20 12:17:07 +103013
Brad Bishop6c2fd812019-07-21 18:08:31 -040014INSANE_SKIP_${PN} = "already-stripped"
15EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
16EXTRA_OEMAKE_class-cross = 'HOSTCC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
17
18inherit uboot-config
19
20do_compile () {
21 oe_runmake ${UBOOT_MACHINE}
22 oe_runmake envtools
23}
24
25do_install () {
26 install -d ${D}${base_sbindir}
27 install -d ${D}${sysconfdir}
28 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
29 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
Adriana Kobylake4778652020-07-07 13:31:51 -050030
31 install -m 644 ${WORKDIR}/${ENV_CONFIG_FILE} ${D}${sysconfdir}/fw_env.config
Brad Bishop6c2fd812019-07-21 18:08:31 -040032}
33
34do_install_class-cross () {
35 install -d ${D}${bindir_cross}
36 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
37 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
38}
39
40SYSROOT_DIRS_append_class-cross = " ${bindir_cross}"
41
42PACKAGE_ARCH = "${MACHINE_ARCH}"
43BBCLASSEXTEND = "cross"