Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 1 | SUMMARY = "Crypt Openssl RSA cpan module" |
| 2 | SECTION = "libs" |
| 3 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a67ceecc5d9a91a5a0d003ba50c26346" |
| 5 | |
| 6 | SRC_URI = "http://www.cpan.org/modules/by-module/Crypt/Crypt-OpenSSL-RSA-${PV}.tar.gz " |
| 7 | |
| 8 | SRC_URI[md5sum] = "d33681e19d2094df7c26bc7a4509265e" |
| 9 | SRC_URI[sha256sum] = "4173403ad4cf76732192099f833fbfbf3cd8104e0246b3844187ae384d2c5436" |
| 10 | |
| 11 | DEPENDS += "libcrypt-openssl-guess-perl-native openssl" |
| 12 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 13 | RDEPENDS:${PN} = " \ |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 14 | libcrypt-openssl-random-perl \ |
| 15 | perl-module-autoloader \ |
| 16 | perl-module-carp \ |
| 17 | perl-module-strict \ |
| 18 | perl-module-warnings \ |
| 19 | perl-module-xsloader \ |
| 20 | " |
| 21 | |
| 22 | EXTRA_CPANFLAGS = "INC='-I${STAGING_INCDIR}' LIBS='-L${STAGING_LIBDIR} -lssl -L${STAGING_DIR_TARGET}${base_libdir} -lcrypto'" |
| 23 | |
| 24 | S = "${WORKDIR}/Crypt-OpenSSL-RSA-${PV}" |
| 25 | |
| 26 | inherit cpan ptest-perl |
| 27 | |
| 28 | do_compile() { |
| 29 | export OTHERLDFLAGS='-Wl,-rpath' |
| 30 | cpan_do_compile |
| 31 | } |
| 32 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 33 | RDEPENDS:${PN}-ptest = " \ |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 34 | ${PN} \ |
| 35 | perl-module-file-copy \ |
| 36 | perl-module-test \ |
| 37 | perl-module-test-more \ |
| 38 | " |