blob: 522c9bda2d58761f92ebdbc6defb1c83baa89bac [file] [log] [blame]
John Wedige519d6b2023-12-08 14:38:41 -08001SUMMARY = "Disable eSPI while the customer's host OS is running"
2DESCRIPTION = "Disable eSPI while an untrusted host OS is running"
3PR = "r1"
4
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
7
8inherit systemd
9
10SRC_URI += " \
11 file://disable-espi.service \
12"
13
14DEPENDS += "systemd"
15
16RDEPENDS:${PN}:append = " \
17 bare-metal-active \
18 espi-control \
19 "
20
21SYSTEMD_PACKAGES = "${PN}"
22SYSTEMD_SERVICE:${PN} = " \
23 disable-espi.service \
24 "
25
26do_install:append() {
27 install -d ${D}${systemd_system_unitdir}
28 install -m 0644 ${WORKDIR}/disable-espi.service ${D}${systemd_system_unitdir}
29}