blob: c8780a4e777b803c1e6db8ce2002a50184791519 [file] [log] [blame]
Joel Stanleye8f268e2018-04-23 10:50:44 +09301HOMEPAGE = "https://github.com/jk-ozlabs/uart-render-controller"
2LICENSE = "GPLv2+"
3
4SRC_URI += "git://github.com/jk-ozlabs/uart-render-controller;branch=master"
5SRC_URI += "file://uart-render-controller.service"
6
7PR = "r1"
8
9LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
10
11inherit autotools
12inherit pkgconfig
13inherit systemd
14
15DEPENDS += "autoconf-archive-native"
16DEPENDS += "systemd"
17RDEPENDS_${PN} += "libsystemd"
18RDEPENDS_${PN} += "fbterm"
19
20SRCREV = "14decab20f621c050760e5f3310f5a960cf21211"
21PV = "0.1+git${SRCPV}"
22
23S = "${WORKDIR}/git"
24
25SYSTEMD_SERVICE_${PN} += "uart-render-controller.service"
26
27do_install_append() {
28 install -d ${D}${systemd_system_unitdir}
29 install -m 0644 ${WORKDIR}/uart-render-controller.service ${D}${systemd_system_unitdir}/
30}