blob: 905ae552a7846c87d62c19aefd1864ec9600bf12 [file] [log] [blame]
Andrew Geisslerea144b032023-01-27 16:03:57 -06001HOMEPAGE = "http://www.denx.de/wiki/U-Boot/WebHome"
2DESCRIPTION = "U-Boot, a boot loader for Embedded boards based on PowerPC, \
3ARM, MIPS and several other processors, which can be installed in a boot \
4ROM and used to initialize and test the hardware or to download and run \
5application code."
6SECTION = "bootloaders"
7DEPENDS += "flex-native bison-native"
8
9LICENSE = "GPL-2.0-or-later"
10LIC_FILES_CHKSUM = "file://Licenses/README;md5=2ca5f2c35c8cc335f0a19756634782f1"
11PE = "1"
12
13# We use the revision in order to avoid having to fetch it from the
14# repo during parse
15SRCREV = "4debc57a3da6c3f4d3f89a637e99206f4cea0a96"
16
17SRC_URI = "git://git.denx.de/u-boot.git;branch=master \
18 "
19
20S = "${WORKDIR}/git"
21B = "${WORKDIR}/build"
22do_configure[cleandirs] = "${B}"
23
24require recipes-bsp/u-boot/u-boot.inc
25
26DEPENDS += "bc-native dtc-native gnutls-native"