blob: 1380638ba7578d6713a0466c743115701363351b [file] [log] [blame]
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05001SUMMARY = "Exif, Iptc and XMP metadata manipulation library and tools"
Andrew Geissler9aee5002022-03-30 16:27:02 +00002LICENSE = "GPL-2.0-only"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05003LIC_FILES_CHKSUM = "file://COPYING;md5=625f055f41728f84a8d7938acc35bdc2"
4
5DEPENDS = "zlib expat"
6
7SRC_URI = "https://exiv2.org/releases/${BPN}-${PV}-Source.tar.gz"
8SRC_URI[sha256sum] = "a79f5613812aa21755d578a297874fb59a85101e793edc64ec2c6bd994e3e778"
9
10# Once patch is obsolete (project should be aware due to PRs), dos2unix can be removed either
11inherit dos2unix
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070012SRC_URI += "file://0001-Use-compiler-fcf-protection-only-if-compiler-arch-su.patch \
13 file://CVE-2021-29457.patch \
14 file://CVE-2021-29458.patch \
15 file://CVE-2021-29463.patch \
16 file://CVE-2021-29464.patch \
17 file://CVE-2021-29470.patch \
18 file://CVE-2021-29473.patch \
19 file://CVE-2021-3482.patch"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050020
21S = "${WORKDIR}/${BPN}-${PV}-Source"
22
23inherit cmake gettext
Andrew Geissler87f5cff2022-09-30 13:13:31 -050024
25do_install:append:class-target() {
26 # reproducibility: remove build host path
27 sed -i ${D}${libdir}/cmake/exiv2/exiv2Config.cmake \
28 -e 's:${STAGING_DIR_HOST}::g'
29}
30