blob: 5d09950040e02e4f0cb2b35a0483d1b24fcd3f6c [file] [log] [blame]
Brad Bishop286d45c2018-10-02 15:21:57 -04001# This class should be included by any recipe that wants to access or provide
2# the platform init source files which are used to initialize a Zynq or ZynqMP
3# SoC.
4
5# Define the path to the xilinx platform init code/headers
6PLATFORM_INIT_DIR ?= "/usr/src/xilinx-platform-init"
7
8PLATFORM_INIT_STAGE_DIR = "${STAGING_DIR_HOST}${PLATFORM_INIT_DIR}"
9
10# Target files use for platform init
11PLATFORM_INIT_FILES ?= ""
12PLATFORM_INIT_FILES_zynq = "ps7_init_gpl.c ps7_init_gpl.h"
13PLATFORM_INIT_FILES_zynqmp = "psu_init_gpl.c psu_init_gpl.h"
14