blob: 1003e9ead859be20f47f56d570f6630aca0e5a1b [file] [log] [blame]
Sergey Solominc7419c62016-08-16 14:18:18 -05001FILES_${PN}-catalog-extralocales = \
2 "${exec_prefix}/lib/systemd/catalog/*.*.catalog"
3PACKAGES =+ "${PN}-catalog-extralocales"
Jayanth Othayoth2a284a02017-09-15 11:11:10 -05004PACKAGECONFIG_append = " networkd"
Sergey Solominc7419c62016-08-16 14:18:18 -05005PACKAGECONFIG_remove = "machined hibernate ldconfig binfmt backlight localed \
6 quotacheck kdbus ima smack polkit logind bootchart utmp"
Brad Bishop11821852015-10-30 03:02:05 -04007FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
8SRC_URI += "file://default.network"
Andrew Geissler1b3762a2017-09-07 14:32:45 -05009SRC_URI += "file://service-restart-policy.conf"
Brad Bishop44a22c22016-08-15 20:16:55 -040010SRC_URI += "file://0001-Export-message_append_cmdline.patch"
Edward A. James3d6db402016-10-14 16:07:14 -050011SRC_URI += "file://0002-systemd-Make-pam-compile-shared-library.patch"
Brad Bishop8ef5fd22017-01-11 20:42:58 -050012SRC_URI += "file://0003-basic-Factor-out-string-checking-from-name_to_prefix.patch"
13SRC_URI += "file://0004-basic-Use-path-escaping-when-mangling-path-instances.patch"
Ratan Gupta87497e82017-07-20 12:08:11 +053014#TODO upstream the below patch via below issue
15#https://github.com/openbmc/openbmc/issues/2016
16SRC_URI += "file://0005-dont-return-error-if-unable-to-create-network-namespace.patch"
Adriana Kobylak72a4a3f2017-06-04 15:41:59 -050017SRC_URI += "file://0006-journal-Create-journald-dbus-object.patch"
18SRC_URI += "file://0007-journal-Add-Synchronize-dbus-method.patch"
Brad Bishop11821852015-10-30 03:02:05 -040019
Brad Bishope3060732016-08-08 20:21:44 -040020RRECOMMENDS_${PN} += "obmc-targets"
Brad Bishop11821852015-10-30 03:02:05 -040021FILES_${PN} += "${libdir}/systemd/network/default.network"
Andrew Geissler1b3762a2017-09-07 14:32:45 -050022FILES_${PN} += "${libdir}/systemd/system.conf.d/service-restart-policy.conf"
Brad Bishop11821852015-10-30 03:02:05 -040023
Edward A. James52523132016-08-04 16:19:18 -050024EXTRA_OECONF += " --disable-hwdb"
25
Brad Bishop11821852015-10-30 03:02:05 -040026do_install_append() {
27 install -m 644 ${WORKDIR}/default.network ${D}${libdir}/systemd/network/
Andrew Geissler1b3762a2017-09-07 14:32:45 -050028 install -m 644 -D ${WORKDIR}/service-restart-policy.conf ${D}${libdir}/systemd/system.conf.d/service-restart-policy.conf
Adriana Kobylakbbf2cb82016-01-30 11:12:10 -060029
30 #TODO Remove after this issue is resolved
31 #https://github.com/openbmc/openbmc/issues/152
32 ln -s /dev/null ${D}/etc/systemd/system/systemd-hwdb-update.service
Brad Bishop11821852015-10-30 03:02:05 -040033}