blob: 0ce242454f0163ef94e55ac5104e16f5e6944d73 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Function returning \"${^GLOBAL_PHASE} eq \'DESTRUCT\'\""
2DESCRIPTION = "Perl's global destruction is a little trick to deal with \
3WRT finalizers because it's not ordered and objects can sometimes disappear."
4
5SECTION = "libs"
6
7HOMEPAGE = "https://metacpan.org/pod/Devel-GlobalDestruction/"
8
9LICENSE = "Artistic-1.0 | GPL-1.0+"
10LIC_FILES_CHKSUM = "file://README;beginline=53;endline=55;md5=935dadb9423774f53548e5cd5055d41a"
11
12SRC_URI = "${CPAN_MIRROR}/authors/id/H/HA/HAARG/Devel-GlobalDestruction-${PV}.tar.gz"
13SRC_URI[md5sum] = "24221ba322cf2dc46a1fc99b53e2380b"
14SRC_URI[sha256sum] = "34b8a5f29991311468fe6913cadaba75fd5d2b0b3ee3bb41fe5b53efab9154ab"
15
16S = "${WORKDIR}/Devel-GlobalDestruction-${PV}"
17
18inherit cpan
19
20RDEPENDS_${PN} = " libsub-exporter-progressive-perl \
21"
22
23BBCLASSEXTEND = "native"