blob: 1dfa048dd0f15d3239f77a2fe2adbafdc2f487e9 [file] [log] [blame]
Adriana Kobylake44af882018-09-21 10:09:36 -05001SUMMARY = "Phosphor IPMI plugin for the Host I/O Mapping Protocol"
2HOMEPAGE = "https://github.com/openbmc/openpower-host-ipmi-flash"
3PR = "r1"
4PV = "0.1+git${SRCPV}"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=ff331e820fda701d36a8f0efc98adc58"
7
8inherit autotools pkgconfig
9inherit obmc-phosphor-ipmiprovider-symlink
10
11DEPENDS += "phosphor-ipmi-host"
12DEPENDS += "autoconf-archive-native"
Patrick Williams46072e32020-04-06 09:13:05 -050013DEPENDS += "sdbusplus"
Adriana Kobylake44af882018-09-21 10:09:36 -050014DEPENDS += "phosphor-logging"
Patrick Williamsd6a06142020-06-09 21:00:08 -050015DEPENDS += "phosphor-dbus-interfaces"
Adriana Kobylake44af882018-09-21 10:09:36 -050016
17TARGET_CFLAGS += "-fpic"
18
19HOSTIPMI_PROVIDER_LIBRARY += "libhiomap.so"
20
21S = "${WORKDIR}/git"
22
23SRC_URI += "git://github.com/openbmc/openpower-host-ipmi-flash"
Andrew Geisslerec321512021-04-27 23:50:20 +000024SRCREV = "61e18614a64866026b5da05b11e51df2b8653bc4"
Adriana Kobylake44af882018-09-21 10:09:36 -050025
26FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
27FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
28FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"