Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | # anonymous support class from originally from angstrom |
| 2 | # |
| 3 | # To use the blacklist, a distribution should include this |
| 4 | # class in the INHERIT_DISTRO |
| 5 | # |
| 6 | # No longer use ANGSTROM_BLACKLIST, instead use a table of |
| 7 | # recipes in PNBLACKLIST |
| 8 | # |
| 9 | # Features: |
| 10 | # |
| 11 | # * To add a package to the blacklist, set: |
| 12 | # PNBLACKLIST[pn] = "message" |
| 13 | # |
| 14 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 15 | python () { |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 16 | blacklist = d.getVarFlag('PNBLACKLIST', d.getVar('PN')) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 17 | |
| 18 | if blacklist: |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 19 | raise bb.parse.SkipRecipe("Recipe is blacklisted: %s" % (blacklist)) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 20 | } |