blob: 505e23255966fa72dcd230c33256a42bf78a7d9f [file] [log] [blame]
Marri Devender Rao84f125e2017-04-27 03:38:39 -05001SUMMARY = "OpenPOWER Debug Collector"
Vishwanatha Subbannaeeae33c2017-06-13 15:00:24 +05302DESCRIPTION = "Application to log error during host checkstop and watchdog timeout"
Marri Devender Rao84f125e2017-04-27 03:38:39 -05003
4PR = "r1"
Patrick Venturee2e5fa72018-10-26 09:43:44 -07005PV = "1.0+git${SRCPV}"
Marri Devender Rao84f125e2017-04-27 03:38:39 -05006
7inherit autotools \
8 pkgconfig \
9 obmc-phosphor-systemd \
Jayanth Othayoth9b2384a2020-02-20 00:13:48 -060010 python3native \
Marri Devender Raodb5a6c42017-09-27 21:55:57 -050011 phosphor-dbus-yaml
Marri Devender Rao84f125e2017-04-27 03:38:39 -050012
Patrick Williams6c9e0142020-04-03 15:45:27 -050013require ${BPN}.inc
Andrew Geissleree126002021-02-01 16:17:23 -060014require ${BPN}-systemd-links.inc
Marri Devender Rao84f125e2017-04-27 03:38:39 -050015
16DEPENDS += " \
17 phosphor-logging \
18 autoconf-archive-native \
Patrick Williamsba5282b2020-03-31 16:43:15 -050019 ${PYTHON_PN}-sdbus++-native \
Marri Devender Rao84f125e2017-04-27 03:38:39 -050020 "
Marri Devender Rao84f125e2017-04-27 03:38:39 -050021S = "${WORKDIR}/git"
22
Vishwanatha Subbannab7f74192017-06-13 14:11:06 +053023# This provides below 2 applications that are called into in case
24# of host checkstop and host watchdog timeout respectively.
25APPS = "checkstop watchdog"
Marri Devender Rao84f125e2017-04-27 03:38:39 -050026
Vishwanatha Subbannab7f74192017-06-13 14:11:06 +053027DEBUG_TMPL = "openpower-debug-collector-{0}@.service"
28SYSTEMD_SERVICE_${PN} += "${@compose_list(d, 'DEBUG_TMPL', 'APPS')}"
29
Marri Devender Raodb5a6c42017-09-27 21:55:57 -050030
31# Do not depend on phosphor-logging for native build
32DEPENDS_remove_class-native = "phosphor-logging"
33
34# Do not depend on phosphor-logging for native SDK build
35DEPENDS_remove_class-nativesdk = "phosphor-logging"
36
37# Provide a means to enable/disable install_error_yaml feature
38PACKAGECONFIG ??= "install_error_yaml"
39PACKAGECONFIG[install_error_yaml] = " \
40 --enable-install_error_yaml, \
41 --disable-install_error_yaml, ,\
42 "
43
44# Enable install_error_yaml during native and native SDK build
45PACKAGECONFIG_add_class-native = "install_error_yaml"
46PACKAGECONFIG_add_class-nativesdk = "install_error_yaml"
47
48# Disable install_error_yaml during target build
49PACKAGECONFIG_remove_class-target = "install_error_yaml"
50
51# Disable generating elog error header file during bitbake. Applications
52# should be using the elog header generated by phosphor-logging recipe
53EXTRA_OECONF += "--disable-gen_errors"
54
55BBCLASSEXTEND += "native nativesdk"