Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | DESCRIPTION = "A tool for transfer files to/from any OBEX enabled device" |
| 2 | LICENSE = "GPLv2 & PD & LGPLv2.1" |
| 3 | LIC_FILES_CHKSUM = "file://LGPL-2.1.txt;md5=4fbd65380cdd255951079008b364516c \ |
| 4 | file://GPL-2.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 5 | file://License.txt;md5=fcbddc3c1debed80dd80da2d3e5f0dc1 \ |
| 6 | " |
| 7 | |
| 8 | DEPENDS += "openobex obexftp-native" |
| 9 | SRC_URI = "http://downloads.sourceforge.net/openobex/${BP}-Source.tar.gz \ |
| 10 | file://Remove_some_printf_in_obexftpd.patch \ |
| 11 | file://0001-apps-CMakeLists.txt-Explicitly-link-libbfb-and-libmu.patch \ |
| 12 | file://make_fuse_swig_optional.patch \ |
| 13 | " |
| 14 | SRC_URI[md5sum] = "157a9d1b2ed220203f7084db906de73c" |
| 15 | SRC_URI[sha256sum] = "d40fb48e0a0eea997b3e582774b29f793919a625d54b87182e31a3f3d1c989a3" |
| 16 | |
| 17 | inherit cmake pkgconfig |
| 18 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 19 | OECMAKE_GENERATOR = "Unix Makefiles" |
| 20 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 21 | PACKAGECONFIG ?= "" |
| 22 | # fuse support will need meta-filesystems layer |
| 23 | PACKAGECONFIG[fuse] = "-DENABLE_FUSE=ON,-DENABLE_FUSE=OFF,fuse" |
| 24 | PACKAGECONFIG[swig] = "-DENABLE_SWIG=ON,-DENABLE_SWIG=OFF,swig" |
| 25 | |
| 26 | DEPENDS_remove_class-native = "fuse-native" |
| 27 | |
| 28 | S = "${WORKDIR}/${BP}-Source" |
| 29 | |
| 30 | EXTRA_OECMAKE += "-DCMAKE_SKIP_RPATH=ON \ |
| 31 | -DENABLE_PERL=OFF -DENABLE_PYTHON=OFF \ |
| 32 | -DENABLE_RUBY=OFF -DENABLE_TCL=OFF \ |
| 33 | " |
| 34 | |
| 35 | do_compile_class-native () { |
| 36 | oe_runmake crctable |
| 37 | } |
| 38 | |
| 39 | do_install_class-native () { |
| 40 | install -D -m 0755 ${B}/bfb/crctable ${D}${bindir}/crctable |
| 41 | } |
| 42 | |
| 43 | BBCLASSEXTEND = "native" |