blob: b6fbb19dc6efac81b217fcf92916596b0362f2c9 [file] [log] [blame]
Brad Bishope1615142020-04-22 14:06:02 -04001FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
2
Ramesh Iyyar1a916df2020-12-07 06:55:34 -06003PACKAGECONFIG_append_rainier = " host-dump-transport-pldm"
4PACKAGECONFIG_append_witherspoon-tacoma = " host-dump-transport-pldm"
Matt Spinlerb9e821a2018-03-29 16:34:38 -05005
Dhruvaraj Subhashchandran21ebf782020-09-24 01:33:00 -05006PACKAGECONFIG_append_rainier = " openpower-dumps-extension"
7PACKAGECONFIG_append_witherspoon-tacoma = " openpower-dumps-extension"
8
Matt Spinlerb9e821a2018-03-29 16:34:38 -05009SRC_URI += "file://plugins.d/ibm_elogall"
Matt Spinler06f97e42020-07-27 16:30:21 -050010SRC_URI += "file://plugins.d/pels"
Matt Spinlerb9e821a2018-03-29 16:34:38 -050011
12install_ibm_plugins() {
13
14 install -m 0755 ${WORKDIR}/plugins.d/ibm_elogall ${D}${dreport_plugin_dir}
Matt Spinler06f97e42020-07-27 16:30:21 -050015 install -m 0755 ${WORKDIR}/plugins.d/pels ${D}${dreport_plugin_dir}
Matt Spinlerb9e821a2018-03-29 16:34:38 -050016
17}
18
19#Link in the plugins so dreport run them at the appropriate time
20python link_ibm_plugins() {
21
22 workdir = d.getVar('WORKDIR', True)
23 script = os.path.join(workdir, 'plugins.d', 'ibm_elogall')
24 install_dreport_user_script(script, d)
Matt Spinler06f97e42020-07-27 16:30:21 -050025
26 script = os.path.join(workdir, 'plugins.d', 'pels')
27 install_dreport_user_script(script, d)
Matt Spinlerb9e821a2018-03-29 16:34:38 -050028}
29
Chirag Sharma4b5211d2020-09-29 08:18:17 -050030#Install dump header script from dreport/ibm.d to dreport/include.d
31install_dreport_header() {
32 install -d ${D}${dreport_include_dir}
33 install -m 0755 ${S}/tools/dreport.d/ibm.d/* ${D}${dreport_include_dir}/
34}
35
36IBM_INSTALL_POSTFUNCS = "install_ibm_plugins link_ibm_plugins"
37IBM_INSTALL_POSTFUNCS_rainier += "install_dreport_header"
38
39do_install[postfuncs] += "${IBM_INSTALL_POSTFUNCS}"