blob: 95e48f0131029d57c13cac13717781f997121927 [file] [log] [blame]
Andrew Geisslereef63862021-01-29 15:58:13 -06001# Copyright (C) 2017 Aaron Brice <aaron.brice@datasoft.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "Administration tool for IP sets"
5HOMEPAGE = "http://ipset.netfilter.org"
6LICENSE = "GPL-2.0"
7LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
8SECTION = "base"
9
10DEPENDS = "libtool libmnl"
11
12SRC_URI = "http://ftp.netfilter.org/pub/ipset/${BP}.tar.bz2"
13SRC_URI[sha256sum] = "b75c13689eddf1d95b396840a69dc04fd7ae4112b10b70594bc0405df7b9b30a"
14
15inherit autotools pkgconfig module-base
16
17EXTRA_OECONF += "-with-kbuild=${KBUILD_OUTPUT} --with-ksource=${STAGING_KERNEL_DIR}"
18
19RRCOMMENDS_${PN} = "\
20 kernel-module-ip-set \
21"