blob: 4f49fb9062dfb8de7e930f496715b23d4071eca7 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "display dialog boxes from shell scripts"
2DESCRIPTION = "Dialog lets you to present a variety of questions \
3or display messages using dialog boxes from a shell \
4script (or any scripting language)."
5HOMEPAGE = "http://invisible-island.net/dialog/"
6SECTION = "console/utils"
7DEPENDS = "ncurses"
8LICENSE = "LGPL-2.1"
9LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343"
10
11SRC_URI = "ftp://ftp.invisible-island.net/${BPN}/${BP}.tgz \
12 "
Andrew Geisslereef63862021-01-29 15:58:13 -060013SRC_URI[md5sum] = "c27db8bb67f71ee32ab1b54a3b3cebc3"
14SRC_URI[sha256sum] = "3c1ed08f44bcf6f159f2aa6fde765db94e8997b3eefb49d8b4c86691693c43e1"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015
16# hardcoded here for use in dialog-static recipe
17S = "${WORKDIR}/dialog-${PV}"
18
19inherit autotools-brokensep pkgconfig
20
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050021PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
22
23PACKAGECONFIG[x11] = "--with-x --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR},--without-x,virtual/libx11"
24
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080025EXTRA_OECONF = "--with-ncurses \
26 --disable-rpath-hack"
27
28do_configure() {
29 gnu-configize --force
30 sed -i 's,${cf_ncuconfig_root}6-config,${cf_ncuconfig_root}-config,g' -i configure
31 sed -i 's,cf_have_ncuconfig=unknown,cf_have_ncuconfig=yes,g' -i configure
32 oe_runconf
33}