blob: a4cb739e8af873e3e0fabbeb1b2f11d1ab605549 [file] [log] [blame]
Marri Devender Raocf233f12019-09-25 03:19:29 -05001FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2SRC_URI += "file://plugins.d/guard"
3
4install_openpower_plugins() {
5 install -m 0755 ${WORKDIR}/plugins.d/guard ${D}${dreport_plugin_dir}
6}
7
8#Link in the plugins so dreport run them at the appropriate time
9python link_openpower_plugins() {
10 workdir = d.getVar('WORKDIR', True)
11 script = os.path.join(workdir, 'plugins.d', 'guard')
12 install_dreport_user_script(script, d)
13}
14
15DEBUG_COLLECTOR_INSTALL_POSTFUNCS ?= ""
16DEBUG_COLLECTOR_INSTALL_POSTFUNCS_df-openpower ?= "install_openpower_plugins link_openpower_plugins"
17
18do_install[postfuncs] += "${DEBUG_COLLECTOR_INSTALL_POSTFUNCS}"