blob: 06eb55ec2955cdceb00b19eef2cc8f8dea0a235c [file] [log] [blame]
Brad Bishop93fb5352015-09-09 03:59:20 +00001SUMMARY = "Phosphor OpenBMC System Management"
2DESCRIPTION = "Phosphor OpenBMC system management reference implementation."
3PR = "r1"
Patrick Venture18624db2018-11-06 08:56:07 -08004LICENSE = "Apache-2.0"
Brad Bishop6f3f0aa2019-09-13 12:14:05 -04005LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Brad Bishop93fb5352015-09-09 03:59:20 +00006
Troy Lee70c128d2021-05-13 15:23:09 +08007inherit obmc-phosphor-dbus-service
Brad Bishop51607d22015-10-18 22:00:15 -04008
Brad Bishop09ad8982016-09-06 22:02:03 -04009PROVIDES += "virtual/obmc-system-mgmt"
Patrick Williams12fc9392021-08-06 09:16:53 -050010RPROVIDES:${PN} += "virtual-obmc-system-mgmt"
Brad Bishop09ad8982016-09-06 22:02:03 -040011
Brad Bishop51607d22015-10-18 22:00:15 -040012S = "${WORKDIR}"
Troy Lee70c128d2021-05-13 15:23:09 +080013SRC_URI += "file://${BPN}.sh"
14
15do_install() {
16 install -d ${D}${bindir}
17 install -m 0755 ${WORKDIR}/${BPN}.sh ${D}${bindir}/${BPN}
18}