Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "Tools for monitoring & limiting user disk usage per filesystem" |
| 2 | SECTION = "base" |
| 3 | HOMEPAGE = "http://sourceforge.net/projects/linuxquota/" |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 4 | DESCRIPTION = "Tools and patches for the Linux Diskquota system as part of the Linux kernel" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 5 | BUGTRACKER = "http://sourceforge.net/tracker/?group_id=18136&atid=118136" |
| 6 | LICENSE = "BSD & GPLv2+ & LGPLv2.1+" |
| 7 | LIC_FILES_CHKSUM = "file://rquota_server.c;beginline=1;endline=20;md5=fe7e0d7e11c6f820f8fa62a5af71230f \ |
| 8 | file://svc_socket.c;beginline=1;endline=17;md5=24d5a8792da45910786eeac750be8ceb" |
| 9 | |
| 10 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/linuxquota/quota-tools/${PV}/quota-${PV}.tar.gz \ |
| 11 | file://fcntl.patch \ |
Andrew Geissler | 09209ee | 2020-12-13 08:44:15 -0600 | [diff] [blame] | 12 | file://0001-quota-Use-realloc-3-instead-of-reallocarray-3.patch \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 13 | " |
Andrew Geissler | 09209ee | 2020-12-13 08:44:15 -0600 | [diff] [blame] | 14 | SRC_URI[sha256sum] = "2f3e03039f378d4f0d97acdb49daf581dcaad64d2e1ddf129495fd579fbd268d" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 15 | |
| 16 | CVE_PRODUCT = "linux_diskquota" |
| 17 | |
| 18 | UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/linuxquota/files/quota-tools/" |
| 19 | UPSTREAM_CHECK_REGEX = "/quota-tools/(?P<pver>(\d+[\.\-_]*)+)/" |
| 20 | |
| 21 | DEPENDS = "gettext-native e2fsprogs libnl dbus" |
| 22 | |
| 23 | inherit autotools-brokensep gettext pkgconfig |
| 24 | |
| 25 | CFLAGS += "${@bb.utils.contains('PACKAGECONFIG', 'rpc', '-I${STAGING_INCDIR}/tirpc', '', d)}" |
| 26 | LDFLAGS += "${@bb.utils.contains('PACKAGECONFIG', 'rpc', '-ltirpc', '', d)}" |
| 27 | ASNEEDED = "" |
| 28 | |
| 29 | PACKAGECONFIG ??= "tcp-wrappers rpc bsd" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 30 | PACKAGECONFIG:libc-musl = "tcp-wrappers rpc" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 31 | |
| 32 | PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers" |
| 33 | PACKAGECONFIG[rpc] = "--enable-rpc,--disable-rpc,libtirpc" |
| 34 | PACKAGECONFIG[bsd] = "--enable-bsd_behaviour=yes,--enable-bsd_behaviour=no," |
| 35 | PACKAGECONFIG[ldapmail] = "--enable-ldapmail,--disable-ldapmail,openldap" |