blob: 1d9daac1f0e20fbb6a740aadc2a5a7bf35ce079b [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "A library to access weather information from online services"
2
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5
6GNOMEBASEBUILDCLASS = "meson"
7
8inherit gnomebase gsettings gobject-introspection gettext gtk-doc vala features_check upstream-version-is-even
9
10SRC_URI[archive.sha256sum] = "ca4e8f2a4baaa9fc6d75d8856adb57056ef1cd6e55c775ba878ae141b6276ee6"
11
12# gobject-introspection is mandatory and cannot be configured
13REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
14UNKNOWN_CONFIGURE_WHITELIST:append = " introspection"
15
16GTKDOC_MESON_OPTION = "gtk_doc"
17
18DEPENDS = " \
19 geocode-glib \
20 gtk+3 \
21 json-glib \
22 libsoup-2.4 \
23 python3-pygobject-native \
24"