blob: 1ffd8918a49ca9996a250a7052a8ed28f0fb58d5 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "nanomsg-next-generation -- light-weight brokerless messaging"
2DESCRIPTION = "NNG, like its predecessors nanomsg (and to some extent ZeroMQ), is a lightweight, broker-less library, offering a simple API to solve common recurring messaging problems, such as publish/subscribe, RPC-style request/reply, or service discovery."
3HOMEPAGE = "https://github.com/nanomsg/nng"
4SECTION = "libs/networking"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a41e579bb4326c21c774f8e51e41d8a3"
7
8SRC_URI = "git://github.com/nanomsg/nng.git"
9SRCREV = "169221da8d53b2ca4fda76f894bee8505887a7c6"
10
11S = "${WORKDIR}/git"
12
13inherit cmake pkgconfig
14
15EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON -DNNG_ENABLE_NNGCAT=ON"
16
17PACKAGECONFIG ??= ""
18
19PACKAGECONFIG[mbedtls] = "-DNNG_ENABLE_TLS=ON,-DNNG_ENABLE_TLS=OFF,mbedtls"
20
21PACKAGES =+ "${PN}-tools"
22FILES:${PN}-tools = "${bindir}/*"