blob: 6d10bfcfd93a35664356056f4de6245771a3c65f [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "A library to abstract stream I/O like serial port, TCP, telnet, etc"
2HOMEPAGE = "https://github.com/cminyard/gensio"
3LICENSE = "GPL-2.0 & LGPL-2.1"
4LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a0fd36908af843bcee10cb6dfc47fa67 \
5 file://COPYING;md5=bae3019b4c6dc4138c217864bd04331f \
6 "
7
8SRCREV = "c500d8705c517f96e591c060105a789f053d2b7a"
9
10SRC_URI = "git://github.com/cminyard/gensio;protocol=https"
11
12S = "${WORKDIR}/git"
13
14inherit autotools
15
16PACKAGECONFIG ??= "openssl tcp-wrappers"
17
18PACKAGECONFIG[openssl] = "--with-openssl=${STAGING_DIR_HOST}${prefix},--without-openssl, openssl"
19PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,--without-tcp-wrappers, tcp-wrappers"
20PACKAGECONFIG[swig] = "--with-swig,--without-swig, swig"
21
22EXTRA_OECONF = "--without-python"
23
24RDEPENDS:${PN} += "bash"