blob: 944f49fc789b491e0a659dad7197c5ecd2f09139 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A library for using PKCS"
2DESCRIPTION = "pkcs11-helper is a library that simplifies the interaction with PKCS \
3providers for end-user applications using a simple API and optional OpenSSL \
4engine. The library allows using multiple PKCS enumerating available token \
5certificates, or selecting a certificate directly by serialized id, handling \
6card removal and card insert events, handling card ie-insert to a different \
7slot, supporting session expiration and much more all using a simple API."
8
9HOMEPAGE = "http://www.opensc-project.org/pkcs11-helper/"
10SECTION = "Development/Libraries"
11
12LICENSE = "GPLv2 & BSD"
13LIC_FILES_CHKSUM = " \
14 file://COPYING;md5=30f10d22cfb1ba98ccd714a41ad3311a \
15 file://COPYING.GPL;md5=8a71d0475d08eee76d8b6d0c6dbec543 \
16 file://COPYING.BSD;md5=66b7a37c3c10483c1fd86007726104d7 \
17"
Andrew Geisslereff27472021-10-29 15:35:00 -050018SRC_URI = "git://github.com/OpenSC/${BPN}.git \
19 file://0001-build-openssl-remove-RSA_SSLV23_PADDING-constant-usa.patch \
20 "
Andrew Geissler82c905d2020-04-13 13:39:40 -050021
22S = "${WORKDIR}/git"
Andrew Geissler4b7c1152020-11-30 19:55:29 -060023# v1.27
24SRCREV = "564a582d600c7eec7b8e303a22b575fd52622174"
Andrew Geissler82c905d2020-04-13 13:39:40 -050025
26UPSTREAM_CHECK_GITTAGREGEX = "pkcs11-helper-(?P<pver>\d+(\.\d+)+)"
27
28DEPENDS = "zlib nettle gnutls gmp openssl nss nspr"
29
30inherit autotools pkgconfig
31
32EXTRA_OECONF = "--disable-static"