blob: fff32372a4c714754abbf0df3787f7a7af4e3149 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "JSON for modern C++"
2HOMEPAGE = "https://nlohmann.github.io/json/"
3SECTION = "libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=441793d25a658d58d79a1f87516a6ad1"
6
7SRC_URI = "git://github.com/nlohmann/json.git;nobranch=1 \
8 "
9
10SRCREV = "fec56a1a16c6e1c1b1f4e116a20e79398282626c"
11
12S = "${WORKDIR}/git"
13
14inherit cmake
15
16EXTRA_OECMAKE += "-DJSON_BuildTests=OFF"
17
18# nlohmann-json is a header only C++ library, so the main package will be empty.
19
20RDEPENDS:${PN}-dev = ""
21
22BBCLASSEXTEND = "native nativesdk"
23
24# other packages commonly reference the file directly as "json.hpp"
25# create symlink to allow this usage
26do_install:append() {
27 ln -s nlohmann/json.hpp ${D}${includedir}/json.hpp
28}