blob: cc037d3934bb466f6ce8ae0fc766de1b8ad01e96 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Protocol Buffers - structured data serialisation mechanism"
2DESCRIPTION = "This is protobuf-c, a C implementation of the Google Protocol Buffers data \
3serialization format. It includes libprotobuf-c, a pure C library that \
4implements protobuf encoding and decoding, and protoc-c, a code generator that \
5converts Protocol Buffer .proto files to C descriptor code, based on the \
6original protoc. protobuf-c formerly included an RPC implementation; that code \
7has been split out into the protobuf-c-rpc project."
8HOMEPAGE = "https://github.com/protobuf-c/protobuf-c"
9SECTION = "console/tools"
10LICENSE = "BSD-2-Clause"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=cb901168715f4782a2b06c3ddaefa558"
12
13DEPENDS = "protobuf-native protobuf"
14
15SRC_URI = "git://github.com/protobuf-c/protobuf-c.git"
16SRCREV = "f224ab2eeb648a818eb20687d7150a285442c907"
17
18S = "${WORKDIR}/git"
19
20inherit autotools pkgconfig
21
22# After several fix attempts there is still a race between generating
23# t.test-full.pb.h and compiling cxx_generate_packed_data.c despite
24# BUILT_SOURCES and explicit dependencies.
25PARALLEL_MAKE = ""
26
27PACKAGE_BEFORE_PN = "${PN}-compiler"
28
29FILES:${PN}-compiler = "${bindir}"
30
31RDEPENDS:${PN}-compiler = "protobuf-compiler"
32RDEPENDS:${PN}-dev += "${PN}-compiler"
33
34BBCLASSEXTEND = "native nativesdk"