blob: 259187b0cd5ec0722549a14bb0ba5de9d6d3b57c [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001DESCRIPTION = "Ice Window Manager (IceWM)"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=4a26952467ef79a7efca4a9cf52d417b"
4
5SRC_URI = "https://github.com/ice-wm/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.lz \
6 file://0001-configure.ac-skip-running-test-program-when-cross-co.patch \
7 "
8SRC_URI[sha256sum] = "12b7cce67b95b09f34873f46948e7f1cef9edd88682139e054b79ba165c53e49"
9
10UPSTREAM_CHECK_URI = "https://github.com/ice-wm/${BPN}/releases"
11
12inherit autotools pkgconfig gettext perlnative features_check qemu update-alternatives
13REQUIRED_DISTRO_FEATURES = "x11"
14
15EXTRA_OECONF += "--with-libdir=${datadir}/icewm \
16 --with-cfgdir=${sysconfdir}/icewm \
17 --with-docdir=${docdir}/icewm \
18 --enable-fribidi \
19 --enable-xinerama \
20 --enable-shape"
21
22DEPENDS = "asciidoc-native fontconfig fribidi gdk-pixbuf imlib2 libxft libxpm libxrandr \
23 libxinerama libice libsm libx11 libxext libxrender libxcomposite libxdamage \
24 libxfixes"
25DEPENDS:append = " qemu-native"
26RDEPENDS:${PN} = "perl fribidi"
27
28do_compile:prepend:class-target() {
29
30 cd ${B}
31 oe_runmake -C src genpref
32
33 qemu_binary="${@qemu_wrapper_cmdline(d, '${STAGING_DIR_TARGET}',['${B}/src/.libs','${STAGING_DIR_TARGET}/${libdir}','${STAGING_DIR_TARGET}/${base_libdir}'])}"
34 cat >qemuwrapper <<EOF
35#!/bin/sh
36${qemu_binary} src/genpref "\$@"
37EOF
38 chmod +x qemuwrapper
39 ./qemuwrapper > src/preferences
40}
41
42ALTERNATIVE:${PN} = "x-session-manager"
43ALTERNATIVE_TARGET[x-session-manager] = "${bindir}/icewm-session"
44ALTERNATIVE_PRIORITY_${PN} = "100"
45
46FILES:${PN} += "${datadir}/xsessions"