blob: a7478d4d5b97f2a8a25265cc605475af4d237c1b [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001# SPDX-FileCopyrightText: Huawei Inc.
2# SPDX-License-Identifier: MIT
3
4# TODO: Pin upstream release (current v7.11.0-80-g419a757)
5src_org = "lvgl"
6SRC_URI = "gitsm://github.com/${src_org}/lv_drivers;destsuffix=${S};protocol=https;nobranch=1"
7SRCREV = "419a757c23aaa67c676fe3a2196d64808fcf2254"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=d6fc0df890c5270ef045981b516bb8f2"
11
12HOMEPAGE = "https://docs.lvgl.io/latest/en/html/porting/index.html"
13SUMMARY = "LVGL's Display and Touch pad drivers"
14DESCRIPTION = "Collection of drivers: SDL, framebuffer, wayland and more..."
15
16DEPENDS += "libxkbcommon"
17DEPENDS += "lvgl"
18DEPENDS += "wayland"
19
20REQUIRED_DISTRO_FEATURES = "wayland"
21
22inherit cmake
23inherit features_check
24
25S = "${WORKDIR}/${PN}-${PV}"
26
27EXTRA_OECMAKE += "-Dinstall:BOOL=ON"
28
29TARGET_CFLAGS += "-DLV_CONF_INCLUDE_SIMPLE=1"
30TARGET_CFLAGS += "-I${RECIPE_SYSROOT}/${includedir}/lvgl"
31
32
33do_configure:append() {
34 [ -r "${S}/lv_drv_conf.h" ] \
35 || sed -e "s|#if 0 .*Set it to \"1\" to enable the content.*|#if 1 // Enabled by ${PN}|g" \
36 -e "s|# define USE_WAYLAND 0|# define USE_WAYLAND 1|g" \
37 < "${S}/lv_drv_conf_template.h" > "${S}/lv_drv_conf.h"
38}
39
40
41FILES:${PN}-dev = "\
42 ${includedir}/lvgl/lv_drivers/ \
43 "
44
45FILES:${PN}-staticdev = "${libdir}/"