blob: 084070c436397540b4be1cdb7c856e615169c659 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001# SPDX-FileCopyrightText: Huawei Inc.
2# SPDX-License-Identifier: MIT
3
4src_org = "lvgl"
5SRC_URI = "gitsm://github.com/${src_org}/lv_lib_png;destsuffix=${S};protocol=https;nobranch=1"
6SRCREV = "bf1531afe07c9f861107559e29ab8a2d83e4715a"
7
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=d6fc0df890c5270ef045981b516bb8f2"
10
11HOMEPAGE = "https://docs.lvgl.io"
12SUMMARY = "PNG decoder for LVGL"
13DESCRIPTION = "Allow the use of PNG images in LVGL. This implementation uses lodepng"
14
15# because of lvgl dependency
16REQUIRED_DISTRO_FEATURES = "wayland"
17
18DEPENDS += "lvgl"
19
20inherit cmake
21inherit features_check
22
23TARGET_CFLAGS += "-DLV_CONF_INCLUDE_SIMPLE=1"
24TARGET_CFLAGS += "-I${RECIPE_SYSROOT}/${includedir}/lvgl"
25
26FILES:${PN}-dev = "\
27 ${includedir}/lvgl/lv_lib_png/ \
28 "
29
30FILES:${PN}-staticdev = "${libdir}/"