blob: 2ca7f60e85e41de51ddb0c6bb0ca8a7e4a8f0120 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001# SPDX-FileCopyrightText: Huawei Inc.
2#
3# SPDX-License-Identifier: MIT
4
5HOMEPAGE = "https://lvgl.io/"
6DESCRIPTION = "LVGL is an OSS graphics library to create embedded GUI"
7SUMMARY = "Light and Versatile Graphics Library"
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://LICENCE.txt;md5=bf1198c89ae87f043108cea62460b03a"
10
11# TODO: Pin upstream release (current is v8.0.3-dev-239-g7b7bed37d)
12SRC_URI = "gitsm://github.com/lvgl/lvgl;destsuffix=${S};protocol=https;nobranch=1"
13SRCREV = "7b7bed37d3e937c59ec99fccba58774fbf9f1930"
14
15REQUIRED_DISTRO_FEATURES = "wayland"
16
17inherit cmake
18inherit features_check
19
20S = "${WORKDIR}/${PN}-${PV}"
21
22EXTRA_OECMAKE += "-Dinstall:BOOL=ON"
23
24do_configure:prepend() {
25 [ -r "${S}/lv_conf.h" ] \
26 || sed -e "s|#if 0 /*Set it to \"1\" to enable the content*/|#if 1 // Enabled by ${PN}|g" \
27 < "${S}/lv_conf_template.h" > "${S}/lv_conf.h"
28}
29
30FILES:${PN}-dev += "\
31 ${includedir}/${PN}/ \
32 ${includedir}/${PN}/lvgl/ \
33 "