blob: a386bb850fa1c52e89137e310969a7cb376a6c03 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001require ttf.inc
2
3SUMMARY = "Japanese TrueType fonts from Vine Linux"
4AUTHOR = "Contributor: noonov <noonov@gmail.com>"
5HOMEPAGE = "http://vlgothic.dicey.org/"
6
7LICENSE = "ttf-mplus & BSD"
8LIC_FILES_CHKSUM = "file://LICENSE.en;md5=cc06b20e7a20bdf6c989624405378303 \
9 file://LICENSE_E.mplus;md5=1c4767416f20215f1e61b970f2117db9 \
10"
11
12SRC_URI = "https://osdn.jp/dl/vlgothic/VLGothic-${PV}.tar.xz"
13
14SRC_URI[sha256sum] = "297a3813675fbea12c5813b55a78091c9a5946515ecbf9fde8b8102e01c579f4"
15
16S = "${WORKDIR}/VLGothic"
17
18do_install:append () {
19 install -D -m644 ${S}/LICENSE_E.mplus ${D}${datadir}/licenses/${PN}/COPYING_MPLUS.txt
20 install -D -m644 ${S}/README.sazanami ${D}${datadir}/licenses/${PN}/COPYING_SAZANAMI.txt
21 install -D -m644 ${S}/LICENSE.en ${D}${datadir}/licenses/${PN}/COPYING_VLGOTHIC.txt
22}
23
24PACKAGES = "${PN}"
25FONT_PACKAGES = "${PN}"
26
27FILES:${PN} = "${datadir}/fonts/truetype ${datadir}/licenses"