blob: 7ce7234528a6667ef70e571ffa681f37057ebe5d [file] [log] [blame]
William A. Kennington III49e95662021-09-15 16:19:36 -07001SUMMARY = "Library for BPF handling"
2DESCRIPTION = "Library for BPF handling"
3HOMEPAGE = "https://github.com/libbpf/libbpf"
4SECTION = "libs"
5LICENSE = "LGPLv2.1+"
6
7LIC_FILES_CHKSUM = "file://../LICENSE.LGPL-2.1;md5=b370887980db5dd40659b50909238dbd"
8
9DEPENDS = "zlib elfutils"
10
11SRC_URI = "git://github.com/libbpf/libbpf.git;protocol=https"
12SRCREV = "5579664205e42194e1921d69d0839f660c801a4d"
13
14PACKAGE_ARCH = "${MACHINE_ARCH}"
15COMPATIBLE_HOST = "(x86_64|i.86|aarch64).*-linux"
16
17S = "${WORKDIR}/git/src"
18
19EXTRA_OEMAKE += "DESTDIR=${D} LIBDIR=${libdir} INCLUDEDIR=${includedir}"
20
21inherit pkgconfig
22
23do_compile() {
24 oe_runmake
25}
26
27do_install() {
28 oe_runmake install
29}