blob: cedcf9fee0a72280d3d10dde3f3a0ffc01c00d7d [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Asio is C++ library for network and low-level I/O programming"
2DESCRIPTION = "Asio is a cross-platform C++ library for network and low-level \
3 I/O programming that provides developers with a consistent asynchronous \
4 model using a modern C++ approach."
5AUTHOR = "Christopher M. Kohlhoff (chris at kohlhoff dot com)"
6HOMEPAGE = "http://think-async.com/Asio"
7SECTION = "libs"
8LICENSE = "BSL-1.0"
9
10DEPENDS = "openssl"
11
12SRC_URI = "${SOURCEFORGE_MIRROR}/asio/${BP}.tar.bz2"
13
14inherit autotools
15
16ALLOW_EMPTY:${PN} = "1"
17
18LIC_FILES_CHKSUM = "file://COPYING;md5=416f4cc4f79551b690babb14ef1a5799"
19
20SRC_URI[sha256sum] = "204374d3cadff1b57a63f4c343cbadcee28374c072dc04b549d772dbba9f650c"
21
22SRC_URI = "${SOURCEFORGE_MIRROR}/asio/${BP}.tar.bz2"
23
24PACKAGECONFIG ??= "boost"
25
26PACKAGECONFIG[boost] = "--with-boost=${STAGING_LIBDIR},--without-boost,boost"
27
28BBCLASSEXTEND = "native nativesdk"